Supported Platforms

For a downloadable list of Supported Platforms, please see the attached document.
 

Altair Accelerator Package – Windows

Platform1 2016.032 2016.09 2017.12 2019.01
Windows 7 Y Y   Y
Windows 8/8.1 Y Y   Y
Windows 10   Y   Y
Windows Server 2008/R2 Y Y    
Windows Server 2012 Y Y   Y
Windows Server 2016       Y
Windows Server 2019        
  1. Windows Support excluded from 2016.09u18, 2016.09u19, 2016.09u20, 2019.01 base release.
  2. Starting with 2016.03 Runtime will only support 64-bit platforms
 

Altair Accelerator Package – Linux

Platform2 2016.031 2016.09 2017.12 2019.01
RHEL 5.x / CentOS 5.x Y Y Y  
RHEL 6.x / CentOS 6.x Y Y Y Y
RHEL 7.x / CentOS 7.x Y Y Y Y
SLES 10.x Y Y Y  
SLES 11.x Y Y Y Y
SLES 12.x Y Y Y Y
SLES 15.x        
Ubuntu 14.04 Y Y Y Y
Ubuntu 16.04 Y Y Y Y
Ubuntu 18.04        
  1. Support for Linux 32 bit will be discontinued starting with 2016.03
  2. Some Runtime utilities are dependent on Python.  Starting with 2016.09 Runtime requires Python versions 2.6 or later
 

Altair Accelerator Package – Mac OS

Platform1
(64 bit)
2016.03 2016.09 2017.12 2019.01
Mac OS X 10.8 Y Y    
Mac OS X 10.9 – 10.10     Y Y
Mac OS X 10.11 – 10.13     Y Y
Mac OS X 10.14        
  1. Some Runtime utilities are dependent on Python.  Starting with 2016.09 Runtime requires Python versions 2.6 or later
 

Altair Accelerator Package Browser Support

Browser1 2016.03 2016.09 2017.12 2019.01
Chrome 60.x+ Y Y Y Y
FireFox55.x+ Y Y Y Y
Microsoft Edge Y Y Y Y
Safari 10.x+ Y Y Y Y
  1. Java Script and Cookies must be supported for all browsers

 

Did you find this article helpful?